• caglararli@hotmail.com
  • 05386281520

CVE-2023-7158 | MicroPython up to 1.21.0 objslice.c slice_indices heap-based overflow (Issue 13007)

Çağlar Arlı      -    30 Views

CVE-2023-7158 | MicroPython up to 1.21.0 objslice.c slice_indices heap-based overflow (Issue 13007)

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. This vulnerability is traded as CVE-2023-7158. It is possible to launch the attack remotely. Furthermore, there is an exploit available. It is recommended to upgrade the affected component.