• caglararli@hotmail.com
  • 05386281520

WSVuls – Website Vulnerability Scanner Detect Issues (Outdated Server Software And Insecure HTTP Headers)

Çağlar Arlı      -    21 Views

WSVuls – Website Vulnerability Scanner Detect Issues (Outdated Server Software And Insecure HTTP Headers)


WSVuls

Website vulnerability scanner detect issues [ outdated server software and insecure HTTP headers.]


What's WSVuls?

WSVuls is a simple and powerful command line tool for Linux, Windows and macOS. It's designed for developers/testers and for those workers in IT who want to test vulnerabilities and analyses website from a single command. It detects issues outdated software version, insecures HTTP headers, the long and useless requests


Why WSVuls ?

WSVuls can extract the following data while crawling:

  • First Byte
  • Start Render
  • FCP
  • Speed Index
  • LCP
  • CLS
  • TBT
  • DC Time
  • DC Requests
  • DC Bytes
  • Time
  • Requests
  • Total Bytes
In Mapper :
  • Resource
  • Request Start
  • Content Type
  • DNS Lookup
  • SSL Negotiation
  • Error/Status Code

Docker

WSVuls can be launched using docker

Build Image
$ git clone https://github.com/anouarbensaad/wsvuls
$ cd wsvuls
$ docker build -t wsvuls:latest .
Run a WSVuls container with interactive mode
$ docker run -it --name wsvuls wsvuls:latest -u facebook.com

Usage

Usage:    wsvuls [options]    Examples:    To scan target url:  $ wsvuls -u facebook.com    You can map all requests from url:  $ wsvuls -u facebook.com --mapper    Flags:    -u, --url       set target website    -m, --mapper    to mapp requests from website    -h, --help      help for wsvuls    -v, --version   version for wsvuls    Use "wsvuls --help" for more information about a command.  

Screenshot